Sunday, June 17, 2012

Upgrading to Skype 4 in Ubuntu 12.04 (from skype 2.2)

The latest version of Skype for Linux is here.  The new 4.0 version brings a number of improvements and brings the Linux Skype client up to speed with the OSX and Windows versions.  If you already have version 2.2 installed you will need to remove it before installing the latest 4.0 version.  I uninstalled my 2.2 version from the software centre but hit the following error when installing the new deb file:

trying to overwrite '/etc/dbus-1/system.d/skype.conf', which is also in package skype-bin:i386

To get around this error just fire up a terminal and run the following commands:

sudo apt-get --purge remove skype

sudo apt-get autoremove

Then just install the latest deb file via the software centre like normal.

Note: I downloaded the Ubuntu 10.04 deb from the Skype download page(there doesn't seem to be a specific 12.04 one)